Will Shazam work on my iPhone?

What are the minimum system requirements for Shazam on my Apple device?

The latest versions of Shazam need iOS 11 and above to run. 

Before updating versions, please remember to save your Shazams by creating a Shazam account. You can create an account using either your email address or Facebook details. If you'd like to use your Facebook, simply login with your Facebook details and you're all set. 

Have more questions? Submit a request